Issuing Processor Service Degradation

Incident Report for Mercantile

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 16:41 UTC

Update

Issuing Processor has fixed their issue. Everything is back to normal.
Posted Oct 27, 2025 - 16:41 UTC

Investigating

Our issuing processor is currently returning 404s for some of our requests. We are investigating with them what the issue might be.
This means that some transactions are delayed and might take some time before appearing on the dashboard.
Posted Oct 27, 2025 - 13:54 UTC
This incident affected: Dashboard and API.