Authentication issues

Incident Report for Mercantile

Resolved

Service is back to normal
Posted Mar 25, 2025 - 19:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 18:32 UTC

Identified

Our authentication provider Auth0 is having issues on some of it's US based servers.
It is possible that you cannot log in your account.
Posted Mar 25, 2025 - 18:21 UTC
This incident affected: Dashboard.