We are continuing to monitor for any further issues.
Posted Oct 14, 2022 - 16:34 UTC
Monitoring
A fix for the visual representation of balances has been implemented and we are monitoring the results.
Posted Oct 14, 2022 - 16:32 UTC
Update
The fix has been deployed to production. Users who were not impacted by this issue and who now make new transactions will not be impacted. Users whose balances were impacted will visually remain incorrect. We are working on fixing the display.
Posted Oct 14, 2022 - 16:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 14, 2022 - 15:29 UTC
Investigating
We have identified an issue that affects the displayed card balance for users with new transactions since October 13. Please know that this uniquely a display issue. Your real balance will be properly displayed latest tomorrow morning 10am EST.