Third-Party Issuing Processor Instability

Incident Report for Mercantile

Resolved

All services are now operating as expected. We apologize for any inconvenience experienced earlier. Thank you for your understanding.
Posted Oct 24, 2023 - 15:26 UTC

Monitoring

All services appear to be back to normal. We are actively monitoring to ensure continued stability. Thank you for your patience and understanding.
Posted Oct 24, 2023 - 14:44 UTC

Investigating

Our platform is currently experiencing instability due to issues with our third-party issuing processor. Features like payments and rewards redemption might be affected. We appreciate your patience and are working diligently to resolve this. Thank you for understanding.
Posted Oct 24, 2023 - 14:34 UTC
This incident affected: Dashboard and API.