Degraded services

Incident Report for Mercantile

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 19:04 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 19:03 UTC

Investigating

Cloud provider outage causes interruptions to our services.
Posted Jul 18, 2025 - 15:50 UTC
This incident affected: Dashboard, API, and Administration Portal.